apt
commandline package manager

NEW: Take a look at the new package tracker: tracker.debian.org/pkg/apt

general

source
apt (source, admin)
version
2.9.1
maint
APT Development Team (a), Michael Vogt (u), Julian Andres Klode (u), David Kalnischkies (u)
arch
any all
std-ver
4.1.1
VCS
Git (browse)

versions ... ...pool

o-o-stable
save 1.8.2.3
o-o-sec
save 1.8.2.2
o-o-upd
save 1.8.2.3
oldstable
save 2.2.4
stable
save 2.6.1
testing
save 2.7.12
unstable
save 2.9.1
Ubuntu
2.7.14build2

todo

problems

  • There were override disparities found in suite unstable:
    • apt: Override says admin - required, .deb says admin - important

testing migration

  • This package is part of the ongoing testing transition known as auto-gnutls28. Please avoid uploads unrelated to this transition, they would likely delay it and require supplementary work from the release managers. On the other hand, if your package has problems preventing it to migrate to testing, please fix them as soon as possible. You can probably find supplementary information in the debian-release archives or in the corresponding release.debian.org bug.
  • This package is part of the ongoing testing transition known as auto-apt. Please avoid uploads unrelated to this transition, they would likely delay it and require supplementary work from the release managers. On the other hand, if your package has problems preventing it to migrate to testing, please fix them as soon as possible. You can probably find supplementary information in the debian-release archives or in the corresponding release.debian.org bug.
  • This package is part of the ongoing testing transition known as auto-db5.3. Please avoid uploads unrelated to this transition, they would likely delay it and require supplementary work from the release managers. On the other hand, if your package has problems preventing it to migrate to testing, please fix them as soon as possible. You can probably find supplementary information in the debian-release archives or in the corresponding release.debian.org bug.
excuses:
  • Migration status for apt (2.6.1 to 2.7.3): BLOCKED: Rejected/violates migration policy/introduces a regression
  • Issues preventing migration:
  • Updating apt would introduce bugs in testing: #1035654
  • Rejected due to piuparts regression - https://piuparts.debian.org/sid/source/a/apt.html
  • missing build on arm64
  • missing build on armel
  • missing build on i386
  • missing build on mips64el
  • missing build on mipsel
  • missing build on ppc64el
  • missing build on s390x
  • arch:arm64 not built yet, autopkgtest delayed there
  • arch:armel not built yet, autopkgtest delayed there
  • arch:i386 not built yet, autopkgtest delayed there
  • arch:ppc64el not built yet, autopkgtest delayed there
  • arch:s390x not built yet, autopkgtest delayed there
  • autopkgtest for apt/2.7.3: amd64: Pass, armhf: Pass
  • Too young, only 1 of 5 days old

news RSS

bugs

all bug history graph
984 (1098)
RC
1
I&N
468 (521)
M&W
513 (574)
F&P
2
NC
5
Ubu
444