choreonoid
Integrated robotics GUI environment

NEW: Take a look at the new package tracker: tracker.debian.org/pkg/choreonoid

general

source
choreonoid (extra, misc)
version
1.5.0+dfsg-0.1
maint
Ubuntu Developers (a)
arch
any all
std-ver
3.9.4
VCS
Git (browse)

todo

  • Incorporate and acknowledge the changes from the non maintainer upload.
  • Lintian reports 13 errors and 205 warnings about this package. You should make the package lintian clean getting rid of them.
  • Build log checks report 2 warnings about this package.
  • The package should be updated to follow the last version of Debian Policy (Standards-Version 4.1.4 instead of 3.9.4).
  • A new upstream version is available: 1.6.0, you should consider packaging it.
  • The BTS contains patches fixing 1 bug, consider including or untagging it.
  • This package has "Build-Depends: libglew-dev" while glew needs a new maintainer, see O #866743.

problems

  • The package has not yet entered testing even though the 5-day delay is over. Check why.
  • The as-installed testing for this package did not pass (log).
  • The package is severely out of date with respect to the Debian Policy. Latest version is 4.1.4 and your package only follows 3.9.4...
  • There were override disparities found in suite unstable:
    • choreonoid: Override says science - optional, .deb says science - extra
    • libcnoid1: Override says libs - optional, .deb says libs - extra
    • libcnoid-dev: Override says libdevel - optional, .deb says libdevel - extra
    • choreonoid-data: Override says science - optional, .deb says science - extra
    • choreonoid-dbg: Override says debug - optional, .deb says debug - extra
    • choreonoid-doc: Override says doc - optional, .deb says doc - extra
    • choreonoid-plugins-base: Override says science - optional, .deb says science - extra

testing migration

excuses:
  • Migration status: BLOCKED: Rejected/introduces a regression (please see below)
  • 612 days old (needed 5 days)
  • choreonoid-plugins-base/armel unsatisfiable Depends: libboost-filesystem1.58.0
  • choreonoid-plugins-base/armel unsatisfiable Depends: libboost-program-options1.58.0
  • choreonoid-plugins-base/armel unsatisfiable Depends: libboost-signals1.58.0
  • choreonoid-plugins-base/armel unsatisfiable Depends: libboost-system1.58.0
  • libcnoid1/armel unsatisfiable Depends: libboost-filesystem1.58.0
  • libcnoid1/armel unsatisfiable Depends: libboost-program-options1.58.0
  • libcnoid1/armel unsatisfiable Depends: libboost-signals1.58.0
  • libcnoid1/armel unsatisfiable Depends: libboost-system1.58.0
  • choreonoid-plugins-base/armhf unsatisfiable Depends: libboost-filesystem1.58.0
  • choreonoid-plugins-base/armhf unsatisfiable Depends: libboost-program-options1.58.0
  • choreonoid-plugins-base/armhf unsatisfiable Depends: libboost-signals1.58.0
  • choreonoid-plugins-base/armhf unsatisfiable Depends: libboost-system1.58.0
  • libcnoid1/armhf unsatisfiable Depends: libboost-filesystem1.58.0
  • libcnoid1/armhf unsatisfiable Depends: libboost-program-options1.58.0
  • libcnoid1/armhf unsatisfiable Depends: libboost-signals1.58.0
  • libcnoid1/armhf unsatisfiable Depends: libboost-system1.58.0
  • missing build on armel: choreonoid, choreonoid-dbg, choreonoid-plugins-base, libcnoid-dev, libcnoid1 (from 1.1.0+dfsg-6.2)
  • missing build on armhf: choreonoid, choreonoid-dbg, choreonoid-plugins-base, libcnoid-dev, libcnoid1 (from 1.1.0+dfsg-6.2)
  • old binaries left on all: choreonoid-data, choreonoid-data, choreonoid-doc, choreonoid-doc (from 1.1.0+dfsg-6.2) (but ignoring cruft, so nevermind)
  • Updating choreonoid introduces new bugs: #811639, #834718, #842763.
  • Piuparts tested OK - https://piuparts.debian.org/sid/source/c/choreonoid.html
  • Not considered

news RSS

bugs

all bug history graph
6
RC
2
I&N
4
M&W
0
F&P
0
Ubu
1