coq-float
Coq library on floating-point arithmetic

NEW: Take a look at the new package tracker: tracker.debian.org/pkg/coq-float

general

source
coq-float (source, libdevel)
version
1:8.4-5
maint
Debian OCaml Maintainers (a), Samuel Mimram (u), Stéphane Glondu (u)
std-ver
3.9.5
VCS
Git (browse)

versions ... ...pool

o-o-stable
save 1:8.3pl1-4
oldstable
save 1:8.4-4
unstable
save 1:8.4-5

binaries

todo

  • Lintian reports 3 warnings about this package. You should make the package lintian clean getting rid of them.
  • The package should be updated to follow the last version of Debian Policy (Standards-Version 4.3.0 instead of 3.9.5).

problems

  • The package has not yet entered testing even though the 5-day delay is over. Check why.
  • Piuparts found an (un)installation error in the Sid version of this package. You should investigate the cause; have a look at the corresponding piuparts log.
  • The package is severely out of date with respect to the Debian Policy. Latest version is 4.3.0 and your package only follows 3.9.5...
  • The package has a debian/watch file, but the last attempt to use it for checking for newer upstream versions failed with an error:
    In watchfile debian/watch, reading webpage   http://lipforge.ens-lyon.fr/frs/?group_id=11&release_id=85 failed: 500 Can't connect to lipforge.ens-lyon.fr:80
  • The URL(s) for this package had some recent persistent issues.

testing migration

excuses:
  • Migration status: BLOCKED: Rejected/introduces a regression
  • 1342 days old (needed 5 days)
  • libfloat-coq/amd64 unsatisfiable Depends: coq-8.4pl4+4.02.3
  • libfloat-coq/arm64 unsatisfiable Depends: coq-8.4pl4+4.02.3
  • libfloat-coq/armel unsatisfiable Depends: coq-8.4pl4+4.02.3
  • libfloat-coq/armhf unsatisfiable Depends: coq-8.4pl4+4.02.3
  • libfloat-coq/i386 unsatisfiable Depends: coq-8.4pl4+4.02.3
  • libfloat-coq/mips unsatisfiable Depends: coq-8.4pl4+4.02.3
  • libfloat-coq/mips64el unsatisfiable Depends: coq-8.4pl4+4.02.3
  • libfloat-coq/mipsel unsatisfiable Depends: coq-8.4pl4+4.02.3
  • libfloat-coq/ppc64el unsatisfiable Depends: coq-8.4pl4+4.02.3
  • libfloat-coq/s390x unsatisfiable Depends: coq-8.4pl4+4.02.3
  • Updating coq-float introduces new bugs: #813596.
  • Cannot be tested by piuparts (not a blocker) - https://piuparts.debian.org/sid/source/c/coq-float.html
  • uninstallable on arch amd64, autopkgtest delayed there
  • Checking build-dependency on amd64
  • Not touching package due to block request by freeze (please contact debian-release if update is needed)

news RSS

bugs

all bug history graph
1
RC
1
I&N
0
M&W
0
F&P
0