docker.io
Linux container runtime

NEW: Take a look at the new package tracker: tracker.debian.org/pkg/docker.io

general

source
docker.io (optional, misc)
version
1.13.1~ds2-3
maint
Tim Potter, Docker Packaging Team (a) (u), Tianon Gravi (u), Paul Tagliamonte (u)
arch
linux-any all
std-ver
3.9.8
VCS
Git (browse)

todo

problems

  • The package has not yet entered testing even though the 5-day delay is over. Check why.
  • The package is severely out of date with respect to the Debian Policy. Latest version is 4.1.3 and your package only follows 3.9.8...
  • There were override disparities found in suite unstable:
    • golang-docker-dev: Override says admin - optional, .deb says oldlibs - extra

testing migration

excuses:
  • Migration status: BLOCKED: Rejected/introduces a regression (please see below)
  • 133 days old (needed 5 days)
  • missing build on i386: docker.io (from 1.11.2~ds1-6)
  • missing build on arm64: docker.io (from 1.11.2~ds1-5)
  • missing build on armel: docker.io (from 1.11.2~ds1-6)
  • missing build on armhf: docker.io (from 1.11.2~ds1-6)
  • missing build on ppc64el: docker.io (from 1.11.2~ds1-6)
  • old binaries left on all: docker-doc, docker-doc, docker-doc, docker-doc, golang-docker-dev, golang-docker-dev, golang-docker-dev, golang-docker-dev, golang-github-docker-docker-dev, golang-github-docker-docker-dev, golang-github-docker-docker-dev, golang-github-docker-docker-dev, vim-syntax-docker, vim-syntax-docker, vim-syntax-docker, vim-syntax-docker (from 1.11.2~ds1-6); docker-doc, golang-docker-dev, golang-github-docker-docker-dev, vim-syntax-docker (from 1.11.2~ds1-5) (but ignoring cruft, so nevermind)
  • Updating docker.io introduces new bugs: #850952, #853248, #858402, #864377, #865975, #881480.
  • Piuparts tested OK - https://piuparts.debian.org/sid/source/d/docker.io.html
  • docker.io unsatisfiable Build-Depends(-Arch) on i386: golang-github-docker-swarmkit-dev (>= 1.12.0+git20170201.779.1c7f003d~)
  • docker.io unsatisfiable Build-Depends(-Arch) on arm64: golang-github-docker-swarmkit-dev (>= 1.12.0+git20170201.779.1c7f003d~)
  • docker.io unsatisfiable Build-Depends(-Arch) on armel: golang-github-docker-swarmkit-dev (>= 1.12.0+git20170201.779.1c7f003d~)
  • docker.io unsatisfiable Build-Depends(-Arch) on armhf: golang-github-docker-swarmkit-dev (>= 1.12.0+git20170201.779.1c7f003d~)
  • docker.io unsatisfiable Build-Depends(-Arch) on ppc64el: golang-github-docker-swarmkit-dev (>= 1.12.0+git20170201.779.1c7f003d~)
  • Depends: docker.io containerd
  • Depends: docker.io docker-libkv
  • Depends: docker.io golang-github-docker-libnetwork
  • Build-Depends(-Arch): docker.io docker-libkv
  • Build-Depends(-Arch): docker.io etcd
  • Build-Depends(-Arch): docker.io golang-github-aanand-compose-file
  • Build-Depends(-Arch): docker.io golang-github-dnephin-cobra
  • Build-Depends(-Arch): docker.io golang-github-docker-engine-api
  • Build-Depends(-Arch): docker.io golang-github-docker-libnetwork
  • Build-Depends(-Arch): docker.io swarmkit
  • Not considered

news RSS

bugs

all bug history graph
37 (43)
RC
5
I&N
29 (35)
M&W
3
F&P
0
Ubu
31