Back to dpkg PTS page

Accepted dpkg 1.14.18 (source i386 all)

Hash: SHA1

Format: 1.7
Date: Tue, 08 Apr 2008 07:00:10 +0300
Source: dpkg
Binary: dpkg dpkg-dev dselect
Architecture: source i386 all
Version: 1.14.18
Distribution: unstable
Urgency: low
Maintainer: Dpkg Developers <>
Changed-By: Guillem Jover <>
 dpkg       - package maintenance system for Debian
 dpkg-dev   - package building tools for Debian
 dselect    - user tool to manage Debian packages
Closes: 473449 473498 473523 473726 474079 474417
 dpkg (1.14.18) unstable; urgency=low
   [ Guillem Jover ]
   * Bump po4a version in Build-Depends to 0.33.1-1, as usage of UTF-8
     in original man pages was causing build failures. Closes: #473498
   * Add triggers documentation to dpkg-dev. Closes: #473449
   * Add deb-triggers.5 and dpkg-trigger.1 man pages, and document new
     statuses and options in dpkg.1.
   [ Raphael Hertzog ]
   * When dpkg-source builds a source package of Format: 2.0 or 3.0 (quilt) it
     applies the patches before the build if
     debian/patches/.dpkg-source-applied doesn't exist. This file is created
     during extraction if patches are applied, and is auto-excluded from the
     debian tarball. This enables on-the-fly conversion of source packages from
     Format: 1.0 to Format: 3.0 (quilt) without manual intervention of the
     user. This feature can be disabled with the option --no-preparation.
   * The dpkg-source option --skip-patches disables application of patches
     during extraction of source packages using Format: 2.0 or Format: 3.0
   * Ensure the Files field is last in *.dsc and *.changes. This is a
     work-around for some braindead dsc parsers (dupload and sbuild for
     instance, see #473518 and #470440).
   * Initialize dependencies for libraries having symbols files with the
     smallest minimal version listed in the symbols file instead of using
     an unversioned dependency. It's the only way to ensure the library
     presence if it wasn't available in all versions of the package that ever
     existed. Closes: #474079
   * Don't use the -p option of diff for Format: 1.0 source packages.
     dpkg-source of sarge doesn't accept data after @@. Closes: #474417
   [ Updated dselect translations ]
   * German. (Sven Joachim).
   * Swedish (Peter Karlsson).
   [ Updated dpkg translations ]
   * Portuguese (Miguel Figueiredo).
   * Simplified Chinese (Deng Xiyue). Closes: #473523
   * Swedish (Peter Karlsson).
   * Vietnamese (Clytie Siddall). Closes: #473726
   [ Updated manpages translations ]
   * German (Helge Kreutzmann).
   * Swedish (Peter Karlsson).
   [ Updated scripts translations ]
   * German (Helge Kreutzmann).
   * Swedish (Peter Karlsson).
 0b779c7f9d9f5d6aafdbbe5049561044 1042 admin required dpkg_1.14.18.dsc
 e11aa8988e93dffd4dd879f09bcc8c28 6484489 admin required dpkg_1.14.18.tar.gz
 b10d911c497168022c9a8741ba8a9d2b 2155164 admin required dpkg_1.14.18_i386.deb
 c1e7e705fd30d8f4a7b5003f3a2869c9 755332 admin optional dselect_1.14.18_i386.deb
 013650eff260efc951283c5e661809f3 660746 utils optional dpkg-dev_1.14.18_all.deb

Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Signed by Raphael Hertzog


  to pool/main/d/dpkg/dpkg-dev_1.14.18_all.deb
  to pool/main/d/dpkg/dpkg_1.14.18.dsc
  to pool/main/d/dpkg/dpkg_1.14.18.tar.gz
  to pool/main/d/dpkg/dpkg_1.14.18_i386.deb
  to pool/main/d/dpkg/dselect_1.14.18_i386.deb