emacs
GNU Emacs editor (metapackage)

NEW: Take a look at the new package tracker: tracker.debian.org/pkg/emacs

general

source
emacs (extra, misc)
version
1:26.1+1-3.2
maint
Rob Browning
arch
any all
std-ver
3.7.2
VCS
Git (browse)

todo

  • Incorporate and acknowledge the changes from the non maintainer upload.
  • Lintian reports 10 warnings about this package. You should make the package lintian clean getting rid of them.
  • Build log checks report 1 warning about this package.
  • The package should be updated to follow the last version of Debian Policy (Standards-Version 4.4.0 instead of 3.7.2).
  • The BTS contains patches fixing 10 bugs (13 if counting merged bugs), consider including or untagging them.
  • This package has "Build-Depends: libgif-dev" while giflib needs a new maintainer, see O #834410.

problems

  • The package is severely out of date with respect to the Debian Policy. Latest version is 4.4.0 and your package only follows 3.7.2...
  • There were override disparities found in suite unstable:
    • emacs25-nox: Override says editors - optional, .deb says oldlibs - optional
    • emacs25: Override says editors - optional, .deb says oldlibs - optional
    • emacs25-lucid: Override says editors - optional, .deb says oldlibs - optional

news RSS

bugs

all bug history graph
77 (91)
RC
0
I&N
58 (68)
M&W
18 (21)
F&P
1 (2)
Ubu
7