gobgp
source package

NEW: Take a look at the new package tracker: tracker.debian.org/pkg/gobgp

general

source
gobgp (optional, misc)
version
1.33-1
maint
Debian Go Packaging Team (a), Vincent Bernat (u)
arch
any all
std-ver
4.1.2
VCS
Git (browse)

versions ... ...pool

oldstable
save 1.15-1
unstable
save 1.33-1
Ubuntu
1.33-1

binaries

todo

  • Lintian reports 3 warnings about this package. You should make the package lintian clean getting rid of them.
  • The package should be updated to follow the last version of Debian Policy (Standards-Version 4.4.1 instead of 4.1.2).
  • A new upstream version is available: 2.9.0, you should consider packaging it.
  • This package has "Build-Depends: golang-github-influxdb-influxdb-dev" while influxdb needs a new maintainer, see RFA #914035.

problems

  • The package has not yet entered testing even though the 5-day delay is over. Check why.
  • There were override disparities found in suite unstable:
    • gobgpd: Override says devel - optional, .deb says net - optional

testing migration

excuses:
  • Migration status for gobgp (- to 1.33-1): BLOCKED: Rejected/violates migration policy/introduces a regression
  • Issues preventing migration:
  • Updating gobgp introduces new bugs: #871692.
  • gobgpd/amd64 has unsatisfiable Built-Using on golang-1.10 1.10.3-1
  • gobgpd/arm64 has unsatisfiable Built-Using on golang-1.8 1.8.3-1
  • gobgpd/armel has unsatisfiable Built-Using on golang-1.10 1.10.3-1
  • gobgpd/armhf has unsatisfiable Built-Using on golang-1.10 1.10.3-1
  • gobgpd/i386 has unsatisfiable Built-Using on golang-1.10 1.10.3-1
  • gobgpd/mipsel has unsatisfiable Built-Using on golang-1.10 1.10.3-1
  • gobgpd/ppc64el has unsatisfiable Built-Using on golang-1.10 1.10.3-1
  • missing build on arm64
  • Additional info:
  • Piuparts tested OK - https://piuparts.debian.org/sid/source/g/gobgp.html
  • 469 days old (needed 5 days)

news RSS

bugs

all bug history graph
1
RC
1
I&N
0
M&W
0
F&P
0