gr-hpsdr
gnuradio interface module for OpenHPSDR protocol 1

NEW: Take a look at the new package tracker: tracker.debian.org/pkg/gr-hpsdr

general

source
gr-hpsdr (optional, misc)
version
3.0-2
maint
Debian Hamradio Maintainers (a), A. Maitland Bottoms (u)
std-ver
4.6.0
VCS
Git (browse)

versions ... ...pool

o-o-stable
save 1.2-1
oldstable
save 1.2.1-2
stable
save 3.0-2
testing
save 3.0-2
unstable
save 3.0-2
Ubuntu
3.0-2build12

binaries

todo

problems

  • The package has not yet entered testing even though the 5-day delay is over. Check why.
  • There were override disparities found in suite unstable:
    • gr-hpsdr: Override says libdevel - optional, .deb says libdevel - extra
  • The package has a debian/watch file, but the last attempt to use it for checking for newer upstream versions failed with an error:
    In debian/watch no matching files for watch line   https://github.com/Tom-McDermott/gr-hpsdr/releases (?:.*?/)?v?(\d[\d.]*)\.tar\.gz debian uupdate

autoremoval from testing

  • Version 3.0-2 of gr-hpsdr is marked for autoremoval from testing on 2024-04-21.
  • It depends (transitively) on pygame and uhd, affected by RC bug(s) 1063085 and 1064708
  • You should try to prevent the removal from testing by fixing these bugs.

testing migration

  • This package is part of the ongoing testing transition known as auto-gnuradio. Please avoid uploads unrelated to this transition, they would likely delay it and require supplementary work from the release managers. On the other hand, if your package has problems preventing it to migrate to testing, please fix them as soon as possible. You can probably find supplementary information in the debian-release archives or in the corresponding release.debian.org bug.
  • This package will soon be part of the python3.12-default transition. You might want to ensure that your package is ready for it. You can probably find supplementary information in the debian-release archives or in the corresponding release.debian.org bug.
excuses:
  • Migration status for gr-hpsdr (1.2.1-2 to 3.0-2): BLOCKED: Cannot migrate due to another item, which is blocked (please check which dependencies are stuck)
  • Issues preventing migration:
  • Build-Depends(-Arch): gr-hpsdr gnuradio (not considered)
  • Depends: gr-hpsdr gnuradio (not considered)
  • Invalidated by build-dependency
  • Invalidated by dependency
  • Additional info:
  • Piuparts tested OK - https://piuparts.debian.org/sid/source/g/gr-hpsdr.html
  • 6 days old (needed 5 days)

news RSS

bugs

all bug history graph
2
RC
0
I&N
1
M&W
1
F&P
0