haskell-vty
source package

NEW: Take a look at the new package tracker: tracker.debian.org/pkg/haskell-vty

general

source
haskell-vty (source, haskell)
version
5.26-1
maint
Debian Haskell Group (a), Clint Adams (u)
arch
any all
std-ver
4.4.0
VCS
Git (browse)

versions ... ...pool

o-o-stable
save 5.2.3-2
oldstable
save 5.11.3-1
stable
save 5.21-3
testing
save 5.25.1-1
unstable
save 5.26-1
Ubuntu
5.25.1-1build2

binaries

todo

  • Lintian reports 2 warnings about this package. You should make the package lintian clean getting rid of them.
  • Build log checks report 1 warning about this package.
  • The package should be updated to follow the last version of Debian Policy (Standards-Version 4.5.0 instead of 4.4.0).
  • A new upstream version is available: 5.29, you should consider packaging it.
  • This package has "Recommends: libjs-mathjax" while mathjax needs a new maintainer, see RFA #950424.

problems

  • The package has not yet entered testing even though the 5-day delay is over. Check why.

testing migration

excuses:
  • Migration status for haskell-vty (5.25.1-1 to 5.26-1): BLOCKED: Rejected/violates migration policy/introduces a regression
  • Issues preventing migration:
  • migrating libghc-vty-dev/5.26-1/amd64 to testing makes libghc-yi-frontend-vty-dev/0.18.0-1+b2/amd64 uninstallable
  • migrating libghc-vty-prof/5.26-1/amd64 to testing makes libghc-yi-frontend-vty-prof/0.18.0-1+b2/amd64 uninstallable
  • migrating libghc-vty-dev/5.26-1/arm64 to testing makes libghc-yi-frontend-vty-dev/0.18.0-1+b2/arm64 uninstallable
  • migrating libghc-vty-prof/5.26-1/arm64 to testing makes libghc-yi-frontend-vty-prof/0.18.0-1+b2/arm64 uninstallable
  • migrating libghc-vty-dev/5.26-1/armel to testing makes libghc-yi-frontend-vty-dev/0.18.0-1+b3/armel uninstallable
  • migrating libghc-vty-prof/5.26-1/armel to testing makes libghc-yi-frontend-vty-prof/0.18.0-1+b3/armel uninstallable
  • migrating libghc-vty-dev/5.26-1/armhf to testing makes libghc-yi-frontend-vty-dev/0.18.0-1+b3/armhf uninstallable
  • migrating libghc-vty-prof/5.26-1/armhf to testing makes libghc-yi-frontend-vty-prof/0.18.0-1+b3/armhf uninstallable
  • migrating libghc-vty-dev/5.26-1/i386 to testing makes libghc-yi-frontend-vty-dev/0.18.0-1+b2/i386 uninstallable
  • migrating libghc-vty-prof/5.26-1/i386 to testing makes libghc-yi-frontend-vty-prof/0.18.0-1+b2/i386 uninstallable
  • migrating libghc-vty-dev/5.26-1/mips64el to testing makes libghc-yi-frontend-vty-dev/0.18.0-1+b2/mips64el uninstallable
  • migrating libghc-vty-prof/5.26-1/mips64el to testing makes libghc-yi-frontend-vty-prof/0.18.0-1+b2/mips64el uninstallable
  • migrating libghc-vty-dev/5.26-1/mipsel to testing makes libghc-yi-frontend-vty-dev/0.18.0-1+b2/mipsel uninstallable
  • migrating libghc-vty-prof/5.26-1/mipsel to testing makes libghc-yi-frontend-vty-prof/0.18.0-1+b2/mipsel uninstallable
  • migrating libghc-vty-dev/5.26-1/ppc64el to testing makes libghc-yi-frontend-vty-dev/0.18.0-1+b2/ppc64el uninstallable
  • migrating libghc-vty-prof/5.26-1/ppc64el to testing makes libghc-yi-frontend-vty-prof/0.18.0-1+b2/ppc64el uninstallable
  • migrating libghc-vty-dev/5.26-1/s390x to testing makes libghc-yi-frontend-vty-dev/0.18.0-1+b2/s390x uninstallable
  • migrating libghc-vty-prof/5.26-1/s390x to testing makes libghc-yi-frontend-vty-prof/0.18.0-1+b2/s390x uninstallable
  • Depends: haskell-vty ghc
  • Depends: haskell-vty haskell-blaze-builder
  • Depends: haskell-vty haskell-hashable
  • Depends: haskell-vty haskell-microlens
  • Depends: haskell-vty haskell-microlens-mtl
  • Depends: haskell-vty haskell-microlens-th
  • Depends: haskell-vty haskell-parallel
  • Depends: haskell-vty haskell-utf8-string
  • Depends: haskell-vty haskell-vector
  • Implicit dependency: haskell-vty haskell-brick
  • Additional info:
  • Piuparts tested OK - https://piuparts.debian.org/sid/source/h/haskell-vty.html
  • 46 days old (needed 5 days)

news RSS

bugs

all bug history graph
0
RC
0
I&N
0
M&W
0
F&P
0