hugs98
source package

NEW: Take a look at the new package tracker: tracker.debian.org/pkg/hugs98

general

source
hugs98 (source, interpreters)
version
98.200609.21-5.4
maint
Isaac Jones, Arjan Oosting (u)
std-ver
3.7.2

todo

  • Incorporate and acknowledge the changes from the non maintainer upload.
  • Lintian reports 49 warnings about this package. You should make the package lintian clean getting rid of them.
  • Build log checks report 2 warnings about this package.
  • The package should be updated to follow the last version of Debian Policy (Standards-Version 4.6.0 instead of 3.7.2).

problems

  • The package is severely out of date with respect to the Debian Policy. Latest version is 4.6.0 and your package only follows 3.7.2...
  • There were override disparities found in suite unstable:
    • libhugs-time-bundled: Override says haskell - optional, .deb says devel - optional
    • libhugs-base-bundled: Override says haskell - optional, .deb says devel - optional
    • libhugs-cabal-bundled: Override says haskell - optional, .deb says devel - optional
    • libhugs-hgl-bundled: Override says haskell - optional, .deb says devel - optional
    • libhugs-fgl-bundled: Override says haskell - optional, .deb says devel - optional
    • libhugs-x11-bundled: Override says haskell - optional, .deb says devel - optional
    • libhugs-haskell98-bundled: Override says haskell - optional, .deb says devel - optional
    • libhugs-quickcheck-bundled: Override says haskell - optional, .deb says devel - optional
    • libhugs-mtl-bundled: Override says haskell - optional, .deb says devel - optional
    • libhugs-unix-bundled: Override says haskell - optional, .deb says devel - optional
    • libhugs-openal-bundled: Override says haskell - optional, .deb says devel - optional
    • libhugs-network-bundled: Override says haskell - optional, .deb says devel - optional
    • libhugs-haskell-src-bundled: Override says haskell - optional, .deb says devel - optional
    • libhugs-xhtml-bundled: Override says haskell - optional, .deb says devel - optional
    • libhugs-opengl-bundled: Override says haskell - optional, .deb says devel - optional
    • libhugs-hunit-bundled: Override says haskell - optional, .deb says devel - optional
    • libhugs-parsec-bundled: Override says haskell - optional, .deb says devel - optional
    • libhugs-stm-bundled: Override says haskell - optional, .deb says devel - optional
    • libhugs-alut-bundled: Override says haskell - optional, .deb says devel - optional
    • libhugs-glut-bundled: Override says haskell - optional, .deb says devel - optional
    • libhugs-haxml-bundled: Override says haskell - optional, .deb says devel - optional
  • This package has been orphaned. This means that it does not have a real maintainer at the moment. Please consider adopting this package if you are interested in it. Please see bug number #907114 for more information.
  • The package has a debian/watch file, but the last attempt to use it for checking for newer upstream versions failed with an error:
    debian/watch is an obsolete version 2 watch file;    please upgrade to a higher version    (see uscan(1) for details).

news RSS

bugs

all bug history graph
12
RC
0
I&N
10
M&W
2
F&P
0