Back to libgweather PTS page

Accepted libgweather 40.0-1 (source) into experimental



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Format: 1.8
Date: Tue, 25 May 2021 19:22:00 +0200
Source: libgweather
Built-For-Profiles: noudeb
Architecture: source
Version: 40.0-1
Distribution: experimental
Urgency: medium
Maintainer: Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>
Changed-By: Marco Trevisan (TreviƱo) <marco@ubuntu.com>
Launchpad-Bugs-Fixed: 1265588 1916827 1918044
Changes:
 libgweather (40.0-1) experimental; urgency=medium
 .
   [ Simon McVittie ]
   * New upstream release (LP: #1918044)
     - Correct value of GWEATHER_PROVIDER_ALL to include OWM
     - Translation updates: be, kk, uk
     - Give better diagnostics on test failure (no functional change)
   * Drop patches that came from upstream
 .
   [ Marco Trevisan (TreviƱo) ]
   * New upstream release (LP: #1916827, LP: #1265588):
     - This version contains a number of API and ABI changes that applications
       will need to be modified for, including:
       + An application-id as well as contact information must be provided for
         every application to use online weather services. For GApplication
         based applications, the application ID is prefilled.
       + All online weather providers are disabled by default, applications
         should enable those that it has verified it can follow the terms of
         service for. Note, for example, the requirement to subscribe to the
         met.no API users mailing-list.
       + A lot of the getter functions for the location database now return
         references to objects which the application will need to handle.
         Applications that use JavaScript or Python bindings should not require
         special handling or this change.
   * debian/libgweather-3-16.install: Install files in libgweather library path.
     It contains locations data in binary form for now (that are
     arch-dependent)
   * debian/libgweather-3-16.symbols: Add new symbols
   * debian: Switch to debhelper 13, and simplify rules accordingly
   * debian/control: Add breaks on rdependent packages that need to be updated.
     This version of libgweather requires some updates on its dependencies,
     even if there was no soname change (and no formal ABI break) we're
     actually breaking the ABI at runtime, so various dependencies will need
     to adapt or be rebuilt.
     In particular e-d-s, gnome-panel and gnome-applets only need to be
     rebuilt against, while gnome-shell, gnome-calendar, gnome-weather and
     wmforecast needs new versions.
     Others, didn't require any change (such as gnome-maps) or may only require
     a rebuild to avoid leaks (as g-s-d, evolution or gnome-initial-setup), but
     this update won't really break them.
   * debian/patches: Cherry-pick upstream locations and translations updates
   * debian/control: Update Standards-Version (no change required)
Checksums-Sha1:
 1b63a5fdbe317200698564761b1a408c619232a7 2701 libgweather_40.0-1.dsc
 5f8be54bb68df8da1193323f17d69c3cb810214d 2704404 libgweather_40.0.orig.tar.xz
 513f54b48a27a38b8ca5243239cabc9b2f438602 130552 libgweather_40.0-1.debian.tar.xz
 82e7d65ee47fd16673950d83651dc67fbfd4919f 18983 libgweather_40.0-1_source.buildinfo
Checksums-Sha256:
 6448cbb972159a43c44fb321dc23bb94e90b7343af881fb5717b089ceb1baf5c 2701 libgweather_40.0-1.dsc
 ca4e8f2a4baaa9fc6d75d8856adb57056ef1cd6e55c775ba878ae141b6276ee6 2704404 libgweather_40.0.orig.tar.xz
 903f52dadced348dfeb3611255846df8999d20652073c82a2fa12bf89e4828c6 130552 libgweather_40.0-1.debian.tar.xz
 c9f3ababe42e9976402b79cda099f4bd96acfa95efc7c40e9c8843ce337cd4e3 18983 libgweather_40.0-1_source.buildinfo
Files:
 173a22747dde89445c175cb8bdca64b5 2701 libs optional libgweather_40.0-1.dsc
 a9c0989890a837982defd8238e1eb356 2704404 libs optional libgweather_40.0.orig.tar.xz
 f72a8f09cd10e2292de5548e17a2a558 130552 libs optional libgweather_40.0-1.debian.tar.xz
 794dd9ef13918f9d19881f491d236611 18983 libs optional libgweather_40.0-1_source.buildinfo

-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEE1MUB2kjreXoIF1CTlEnC9QmWY18FAmCtMuUACgkQlEnC9QmW
Y19ijQ/9HI5YfOj8OW95KvQMuXs7suH3uG5izglIBf97iSTqhFAoVBrSHxYXxLLP
SyqtKCXjfYMsR03efIYe6/aIZ3shANLqkvUYpwmzmWFmDNBGvmOkWQkoSfVpPDMO
iCM7XTUxL115SmOJIDrwZ+n9Zw9fTSjGOrx0ZHuWazAEoE8+O5y8QTqAzWjBNeTh
EJZYVRTJSSBJG8f+tV3Wnhdmt8qFXeimnz0LHCsVRJdV2Ehexq7ic/Kno/Vmvhgr
DXBhrIiTp+28ZwNr+RlMXcczO7rbV51fHsQBGaO+xiXE9+T91HXkeE9Mho1PM24h
WapSxHH5wRHejRjy/XwPwKvRTPCgBlTH4enGfVkRoUkBZcnG5j1aKto9VvdXKNkS
IUVa8YqqpJ0KfA9kfgRg4W9XdZWwnLxUBXBZcKVDLEgyAJkGaLEiVXdFrb57fdnO
NT/nsd0Pnf9MXNKZ2QrGiPhKsnwnLKeYiHDEf4B8OYvET51UL2mucLyV8xw1APkQ
a3G7tRisQqiDHHv5i82bmp76CoKn6hFlG5BjoYO8zBt9oSk8oQnwDAOApuBlA3XP
5gwzGIXmg0Kbk3F77ydY2KIXkj2qHfbOcFrW5nKE7gtKA53jNp6qkpV2g2oSKTRE
KTrTVQv33GQj4upAfzNUvPOWvp68CywBZsEQ0eyGX90M1Ug+KbE=
=zHzs
-----END PGP SIGNATURE-----