mitmproxy
SSL-capable man-in-the-middle HTTP proxy

NEW: Take a look at the new package tracker: tracker.debian.org/pkg/mitmproxy

general

source
mitmproxy (source, net)
version
0.18.2-6
maint
Sebastien Delafond
std-ver
3.9.8
VCS
Git (browse)

versions ... ...pool

o-o-stable
save 0.8-2
oldstable
save 0.10.1-2
stable
save 0.18.2-6
unstable
save 0.18.2-6

binaries

todo

  • Lintian reports 3 warnings about this package. You should make the package lintian clean getting rid of them.
  • The package should be updated to follow the last version of Debian Policy (Standards-Version 4.1.3 instead of 3.9.8).
  • A new upstream version is available: 2.0.2, you should consider packaging it.
  • The BTS contains patches fixing 1 bug, consider including or untagging it.

problems

  • The package has not yet entered testing even though the 5-day delay is over. Check why.
  • Piuparts found an (un)installation error in the Sid version of this package. You should investigate the cause; have a look at the corresponding piuparts log.
  • The package is severely out of date with respect to the Debian Policy. Latest version is 4.1.3 and your package only follows 3.9.8...
  • The URL(s) for this package had some recent persistent issues.

testing migration

excuses:
  • Migration status: BLOCKED: Rejected/introduces a regression (please see below)
  • 396 days old (needed 5 days)
  • mitmproxy/amd64 unsatisfiable Depends: python-hyperframe (<< 5)
  • mitmproxy/i386 unsatisfiable Depends: python-hyperframe (<< 5)
  • mitmproxy/arm64 unsatisfiable Depends: python-hyperframe (<< 5)
  • mitmproxy/armel unsatisfiable Depends: python-hyperframe (<< 5)
  • mitmproxy/armhf unsatisfiable Depends: python-hyperframe (<< 5)
  • mitmproxy/mips unsatisfiable Depends: python-hyperframe (<< 5)
  • mitmproxy/mips64el unsatisfiable Depends: python-hyperframe (<< 5)
  • mitmproxy/mipsel unsatisfiable Depends: python-hyperframe (<< 5)
  • mitmproxy/ppc64el unsatisfiable Depends: python-hyperframe (<< 5)
  • mitmproxy/s390x unsatisfiable Depends: python-hyperframe (<< 5)
  • Updating mitmproxy introduces new bugs: #867250, #867278, #869615.
  • Rejected due to piuparts regression - https://piuparts.debian.org/sid/source/m/mitmproxy.html
  • Not considered

news RSS

bugs

all bug history graph
6
RC
3
I&N
2
M&W
1
F&P
0