mono-tools
source package

NEW: Take a look at the new package tracker: tracker.debian.org/pkg/mono-tools

general

source
mono-tools (source, cli-mono)
version
4.2-3
maint
Debian Mono Group (a), Mirco Bauer (u), Sebastian Dröge (u)
std-ver
3.9.2
VCS
Git (browse)

versions ... ...pool

o-o-stable
save 2.10-6
oldstable
save 3.10-1
stable
save 4.2-2
testing
save 4.2-2.2
unstable
save 4.2-3
Ubuntu
4.2-3

todo

problems

  • The package is severely out of date with respect to the Debian Policy. Latest version is 4.3.0 and your package only follows 3.9.2...
  • There were override disparities found in suite unstable:
    • mono-tools-gui: Override says cli-mono - optional, .deb says devel - optional
    • mono-profiler: Override says cli-mono - optional, .deb says devel - optional
    • mono-tools-devel: Override says cli-mono - optional, .deb says devel - optional
  • The URL(s) for this package had some recent persistent issues.

testing migration

excuses:
  • Migration status: Waiting for test results, another package or too young (no action required now - check later)
  • Too young, only 4 of 10 days old
  • gendarme/mips unsatisfiable Depends: mono-runtime (>= 3.0~)
  • gendarme/mips64el unsatisfiable Depends: mono-runtime (>= 3.0~)
  • mono-profiler/mips unsatisfiable Depends: libmono-profiler
  • mono-profiler/mips unsatisfiable Depends: mono-runtime (>= 3.0~)
  • mono-profiler/mips unsatisfiable Depends: libglib2.0-cil (>= 2.12.40)
  • mono-profiler/mips unsatisfiable Depends: libgtk2.0-cil (>= 2.12.40)
  • mono-profiler/mips64el unsatisfiable Depends: libmono-profiler
  • mono-profiler/mips64el unsatisfiable Depends: mono-runtime (>= 3.0~)
  • mono-profiler/mips64el unsatisfiable Depends: libglib2.0-cil (>= 2.12.40)
  • mono-profiler/mips64el unsatisfiable Depends: libgtk2.0-cil (>= 2.12.40)
  • mono-tools-devel/mips unsatisfiable Depends: mono-runtime (>= 3.0~)
  • mono-tools-devel/mips64el unsatisfiable Depends: mono-runtime (>= 3.0~)
  • mono-tools-gui/mips unsatisfiable Depends: mono-runtime (>= 3.0~)
  • mono-tools-gui/mips unsatisfiable Depends: libglib2.0-cil (>= 2.12.40)
  • mono-tools-gui/mips unsatisfiable Depends: libgtk2.0-cil (>= 2.12.40)
  • mono-tools-gui/mips64el unsatisfiable Depends: mono-runtime (>= 3.0~)
  • mono-tools-gui/mips64el unsatisfiable Depends: libglib2.0-cil (>= 2.12.40)
  • mono-tools-gui/mips64el unsatisfiable Depends: libgtk2.0-cil (>= 2.12.40)
  • Updating mono-tools fixes old bugs: #921793
  • Piuparts tested OK - https://piuparts.debian.org/sid/source/m/mono-tools.html
  • Checking build-dependency on amd64
  • Checking build-dependency (indep) on amd64

news RSS

bugs

all bug history graph
4
RC
0
I&N
3
M&W
1
F&P
0
Ubu
14