ocaml-ipaddr
source package

NEW: Take a look at the new package tracker: tracker.debian.org/pkg/ocaml-ipaddr

general

source
ocaml-ipaddr (extra, misc)
version
2.7.0-2
maint
Debian OCaml Maintainers (a), Stéphane Glondu (u)
std-ver
3.9.8
VCS
Git (browse)

versions ... ...pool

oldstable
save 2.5.0-1
stable
save 2.7.0-2
unstable
save 2.7.0-2

binaries

todo

  • Lintian reports 2 warnings about this package. You should make the package lintian clean getting rid of them.
  • The package should be updated to follow the last version of Debian Policy (Standards-Version 4.3.0 instead of 3.9.8).
  • A new upstream version is available: 3.0.0, you should consider packaging it.

problems

  • The package has not yet entered testing even though the 5-day delay is over. Check why.
  • Piuparts found an (un)installation error in the Sid version of this package. You should investigate the cause; have a look at the corresponding piuparts log.
  • The package is severely out of date with respect to the Debian Policy. Latest version is 4.3.0 and your package only follows 3.9.8...
  • The URL(s) for this package had some recent persistent issues.

testing migration

excuses:
  • Migration status: BLOCKED: Needs an approval (either due to a freeze, the source suite or a manual hint)
  • 1040 days old (needed 5 days)
  • libipaddr-ocaml/amd64 unsatisfiable Depends: ocaml-base-nox-4.02.3
  • libipaddr-ocaml/arm64 unsatisfiable Depends: ocaml-base-nox-4.02.3
  • libipaddr-ocaml/armel unsatisfiable Depends: ocaml-base-nox-4.02.3
  • libipaddr-ocaml/armhf unsatisfiable Depends: ocaml-base-nox-4.02.3
  • libipaddr-ocaml/i386 unsatisfiable Depends: ocaml-base-nox-4.02.3
  • libipaddr-ocaml/mips unsatisfiable Depends: ocaml-base-nox-4.02.3
  • libipaddr-ocaml/mips64el unsatisfiable Depends: ocaml-base-nox-4.02.3
  • libipaddr-ocaml/mipsel unsatisfiable Depends: ocaml-base-nox-4.02.3
  • libipaddr-ocaml/ppc64el unsatisfiable Depends: ocaml-base-nox-4.02.3
  • libipaddr-ocaml/s390x unsatisfiable Depends: ocaml-base-nox-4.02.3
  • libipaddr-ocaml-dev/amd64 unsatisfiable Depends: ocaml-nox-4.02.3
  • libipaddr-ocaml-dev/arm64 unsatisfiable Depends: ocaml-nox-4.02.3
  • libipaddr-ocaml-dev/armel unsatisfiable Depends: ocaml-nox-4.02.3
  • libipaddr-ocaml-dev/armhf unsatisfiable Depends: ocaml-nox-4.02.3
  • libipaddr-ocaml-dev/i386 unsatisfiable Depends: ocaml-nox-4.02.3
  • libipaddr-ocaml-dev/mips unsatisfiable Depends: ocaml-nox-4.02.3
  • libipaddr-ocaml-dev/mips64el unsatisfiable Depends: ocaml-nox-4.02.3
  • libipaddr-ocaml-dev/mipsel unsatisfiable Depends: ocaml-nox-4.02.3
  • libipaddr-ocaml-dev/ppc64el unsatisfiable Depends: ocaml-nox-4.02.3
  • libipaddr-ocaml-dev/s390x unsatisfiable Depends: ocaml-nox-4.02.3
  • Cannot be tested by piuparts (not a blocker) - https://piuparts.debian.org/sid/source/o/ocaml-ipaddr.html
  • uninstallable on arch amd64, autopkgtest delayed there
  • Not touching package due to block request by freeze (please contact debian-release if update is needed)
  • Build-Depends(-Arch): ocaml-ipaddr ppx-sexp-conv
  • Depends: ocaml-ipaddr sexplib310

news RSS

bugs

all bug history graph
0
RC
0
I&N
0
M&W
0
F&P
0