perl
Larry Wall's Practical Extraction and Report Language

NEW: Take a look at the new package tracker: tracker.debian.org/pkg/perl

general

source
perl (source, perl)
version
5.26.0-4
maint
Niko Tyni, Dominic Hargreaves (u)
arch
any all
std-ver
3.9.8
VCS
Git (browse)

todo

problems

  • The package is severely out of date with respect to the Debian Policy. Latest version is 4.0.0 and your package only follows 3.9.8...
  • There were override disparities found in suite unstable:
    • perl-debug: Override says debug - optional, .deb says devel - extra
  • The BTS contains 1 bug tagged help, please consider helping the maintainer in dealing with it.
  • The package has a debian/watch file, but the last attempt to use it for checking for newer upstream versions failed with an error:

testing migration

  • This package is part of the ongoing testing transition known as auto-perl. Please avoid uploads unrelated to this transition, they would likely delay it and require supplementary work from the release managers. On the other hand, if your package has problems preventing it to migrate to testing, please fix them as soon as possible. You can probably find supplementary information in the debian-release archives or in the corresponding release.debian.org bug.
  • This package will soon be part of the auto-gdbm transition. You might want to ensure that your package is ready for it. You can probably find supplementary information in the debian-release archives or in the corresponding release.debian.org bug.
  • This package is part of the ongoing testing transition known as perl5.26. Please avoid uploads unrelated to this transition, they would likely delay it and require supplementary work from the release managers. On the other hand, if your package has problems preventing it to migrate to testing, please fix them as soon as possible. You can probably find supplementary information in the debian-release archives or in the corresponding release.debian.org bug.
excuses:
  • Migration status: WAITING: Waiting for test results, another package or too young (no action required now - check later)
  • Too young, only 2 of 5 days old
  • old binaries left on amd64: libperl5.24, perl-modules-5.24 (from 5.24.1-7) (but ignoring cruft, so nevermind)
  • old binaries left on i386: libperl5.24, perl-modules-5.24 (from 5.24.1-7) (but ignoring cruft, so nevermind)
  • old binaries left on arm64: libperl5.24, perl-modules-5.24 (from 5.24.1-7) (but ignoring cruft, so nevermind)
  • old binaries left on armel: libperl5.24, perl-modules-5.24 (from 5.24.1-7) (but ignoring cruft, so nevermind)
  • old binaries left on armhf: libperl5.24, perl-modules-5.24 (from 5.24.1-7) (but ignoring cruft, so nevermind)
  • old binaries left on mips: libperl5.24, perl-modules-5.24 (from 5.24.1-7) (but ignoring cruft, so nevermind)
  • old binaries left on mips64el: libperl5.24, perl-modules-5.24 (from 5.24.1-7) (but ignoring cruft, so nevermind)
  • old binaries left on mipsel: libperl5.24, perl-modules-5.24 (from 5.24.1-7) (but ignoring cruft, so nevermind)
  • old binaries left on ppc64el: libperl5.24, perl-modules-5.24 (from 5.24.1-7) (but ignoring cruft, so nevermind)
  • old binaries left on s390x: libperl5.24, perl-modules-5.24 (from 5.24.1-7) (but ignoring cruft, so nevermind)
  • Piuparts tested OK - https://piuparts.debian.org/sid/source/p/perl.html
  • Not considered

news RSS

bugs

all bug history graph
179 (185)
RC
1
I&N
57 (59)
M&W
121 (125)
F&P
0
Help
1
Ubu
120