prospector
comprehensive static Python code analyzer

NEW: Take a look at the new package tracker: tracker.debian.org/pkg/prospector

general

source
prospector (optional, devel)
version
0.12.7-2.1
maint
Python Applications Packaging Team (a), ChangZhuo Chen (陳昌倬) (u)
std-ver
4.0.0
VCS
Git (browse)

versions ... ...pool

stable
save 0.12.4-2
unstable
save 0.12.7-2.1

binaries

todo

  • Incorporate and acknowledge the changes from the non maintainer upload.
  • Lintian reports 2 warnings about this package. You should make the package lintian clean getting rid of them.
  • The package should be updated to follow the last version of Debian Policy (Standards-Version 4.3.0 instead of 4.0.0).
  • A new upstream version is available: 1.1.1, you should consider packaging it.

problems

  • The package has not yet entered testing even though the 2-day delay is over. Check why.
  • The URL(s) for this package had some recent persistent issues.

testing migration

excuses:
  • Migration status: BLOCKED: Rejected/introduces a regression
  • 100 days old (needed 2 days)
  • Updating prospector introduces new bugs: #896624, #919793.
  • Piuparts tested OK - https://piuparts.debian.org/sid/source/p/prospector.html
  • Required age reduced by 3 days because of autopkgtest
  • Checking build-dependency on amd64
  • Not touching package due to block request by freeze (please contact debian-release if update is needed)
  • Build-Depends(-Arch): prospector pylint-flask
  • Depends: prospector pylint-flask

news RSS

bugs

all bug history graph
2
RC
2
I&N
0
M&W
0
F&P
0