rust-cargo-outdated
Cargo subcommand for displaying when dependencies are out of date

NEW: Take a look at the new package tracker: tracker.debian.org/pkg/rust-cargo-outdated

general

source
rust-cargo-outdated (extra, misc)
version
0.9.9-2
maint
Debian Rust Maintainers, Ximin Luo (u)
std-ver
4.5.1
VCS
Git (browse)

versions ... ...pool

unstable
save 0.9.9-2
Ubuntu
0.9.9-2

binaries

todo

  • Lintian reports 2 warnings about this package. You should make the package lintian clean getting rid of them.
  • Build log checks report 2 warnings about this package.
  • The package should be updated to follow the last version of Debian Policy (Standards-Version 4.6.0 instead of 4.5.1).
  • A new upstream version is available: 0.10.2, you should consider packaging it.

problems

  • The package has not yet entered testing even though the 5-day delay is over. Check why.

testing migration

excuses:
  • Migration status for rust-cargo-outdated (- to 0.9.9-2): BLOCKED: Rejected/violates migration policy/introduces a regression
  • Issues preventing migration:
  • rust-cargo-outdated unsatisfiable Build-Depends(-Arch) on amd64: librust-cargo-0.43+default-dev (>= 0.43.1-~~)
  • rust-cargo-outdated unsatisfiable Build-Depends(-Arch) on amd64: librust-env-logger-0.7+default-dev
  • rust-cargo-outdated unsatisfiable Build-Depends(-Arch) on arm64: librust-cargo-0.43+default-dev (>= 0.43.1-~~)
  • rust-cargo-outdated unsatisfiable Build-Depends(-Arch) on arm64: librust-env-logger-0.7+default-dev
  • rust-cargo-outdated unsatisfiable Build-Depends(-Arch) on armel: librust-cargo-0.43+default-dev (>= 0.43.1-~~)
  • rust-cargo-outdated unsatisfiable Build-Depends(-Arch) on armel: librust-env-logger-0.7+default-dev
  • rust-cargo-outdated unsatisfiable Build-Depends(-Arch) on armhf: librust-cargo-0.43+default-dev (>= 0.43.1-~~)
  • rust-cargo-outdated unsatisfiable Build-Depends(-Arch) on armhf: librust-env-logger-0.7+default-dev
  • rust-cargo-outdated unsatisfiable Build-Depends(-Arch) on i386: librust-cargo-0.43+default-dev (>= 0.43.1-~~)
  • rust-cargo-outdated unsatisfiable Build-Depends(-Arch) on i386: librust-env-logger-0.7+default-dev
  • rust-cargo-outdated unsatisfiable Build-Depends(-Arch) on mips64el: librust-cargo-0.43+default-dev (>= 0.43.1-~~)
  • rust-cargo-outdated unsatisfiable Build-Depends(-Arch) on mips64el: librust-env-logger-0.7+default-dev
  • rust-cargo-outdated unsatisfiable Build-Depends(-Arch) on ppc64el: librust-cargo-0.43+default-dev (>= 0.43.1-~~)
  • rust-cargo-outdated unsatisfiable Build-Depends(-Arch) on ppc64el: librust-env-logger-0.7+default-dev
  • rust-cargo-outdated unsatisfiable Build-Depends(-Arch) on s390x: librust-cargo-0.43+default-dev (>= 0.43.1-~~)
  • rust-cargo-outdated unsatisfiable Build-Depends(-Arch) on s390x: librust-env-logger-0.7+default-dev
  • missing build on armel
  • Additional info:
  • Piuparts tested OK - https://piuparts.debian.org/sid/source/r/rust-cargo-outdated.html
  • 277 days old (needed 5 days)

news RSS

bugs

all bug history graph
1
RC
0
I&N
1
M&W
0
F&P
0