rustc
Rust systems programming language

NEW: Take a look at the new package tracker: tracker.debian.org/pkg/rustc

general

source
rustc (optional, rust)
version
1.25.0+dfsg1-2
maint
Rust Maintainers (a), Jordan Justen (u), Luca Bruno (u), Sylvestre Ledru (u), Angus Lees (u), Ximin Luo (u)
arch
any all
std-ver
4.1.3
VCS
Git (browse)

todo

  • Lintian reports 7 warnings about this package. You should make the package lintian clean getting rid of them.
  • Build log checks report 1 warning about this package.
  • The package should be updated to follow the last version of Debian Policy (Standards-Version 4.1.4 instead of 4.1.3).
  • A new upstream version is available: 1.26.0, you should consider packaging it.

problems

  • The package has not yet entered testing even though the 5-day delay is over. Check why.
  • There were override disparities found in suite unstable:
    • rust-gdb: Override says rust - optional, .deb says devel - optional
    • rustc: Override says rust - optional, .deb says devel - optional
    • libstd-rust-dev: Override says rust - optional, .deb says libdevel - optional
    • rust-lldb: Override says rust - optional, .deb says devel - optional
    • rust-doc: Override says rust - optional, .deb says doc - optional
  • There were override disparities found in suite experimental:
    • rust-gdb: Override says rust - optional, .deb says devel - optional
    • rustc: Override says rust - optional, .deb says devel - optional
    • libstd-rust-dev: Override says rust - optional, .deb says libdevel - optional
    • rust-lldb: Override says rust - optional, .deb says devel - optional
    • rust-doc: Override says rust - optional, .deb says doc - optional

testing migration

excuses:
  • Migration status: BLOCKED: Rejected/introduces a regression
  • 6 days old (needed 5 days)
  • rust-lldb/mips64el unsatisfiable Depends: lldb-6.0
  • rust-lldb/mips64el unsatisfiable Depends: python-lldb-6.0
  • rust-lldb/ppc64el unsatisfiable Depends: lldb-6.0
  • rust-lldb/ppc64el unsatisfiable Depends: python-lldb-6.0
  • rust-lldb/s390x unsatisfiable Depends: lldb-6.0
  • rust-lldb/s390x unsatisfiable Depends: python-lldb-6.0
  • missing build on mips64el: libstd-rust-1.25, libstd-rust-dev, rustc (from 1.25.0+dfsg1-1)
  • old binaries left on all: rust-doc, rust-gdb, rust-lldb, rust-src (from 1.25.0+dfsg1-1) (but ignoring cruft, so nevermind)
  • Updating rustc introduces new bugs: #899180.
  • Piuparts tested OK - https://piuparts.debian.org/sid/source/r/rustc.html
  • Build-Depends(-Arch): rustc cargo

news RSS

bugs

all bug history graph
5
RC
0
I&N
4
M&W
1
F&P
0
Ubu
4