sagemath
Open Source Mathematical Software

NEW: Take a look at the new package tracker: tracker.debian.org/pkg/sagemath

general

source
sagemath (optional, misc)
version
9.5-6
maint
Debian Math Team, Tobias Hansen (u), Julien Puydt (u), Jerome Benoit (u), Ximin Luo (u)
arch
all amd64 arm64 i386 ppc64el s390x alpha hppa hurd-i386 ia64 kfreebsd-amd64 kfreebsd-i386 m68k powerpc ppc64 riscv64 sh4 sparc64 x32
std-ver
4.6.2
VCS
Git (browse)

versions ... ...pool

o-o-stable
save 8.6-6
oldstable
save 9.2-2
stable
save 9.5-6
unstable
save 9.5-6

binaries

todo

  • Lintian reports 7 errors and 77225 warnings about this package. You should make the package lintian clean getting rid of them.
  • The package should be updated to follow the last version of Debian Policy (Standards-Version 4.7.0 instead of 4.6.2).
  • A new upstream version is available: 10.3, you should consider packaging it.
  • The BTS contains patches fixing 1 bug, consider including or untagging it.
  • This package has "Build-Depends: yasm" while yasm needs a new maintainer, see O #1011573.

problems

  • The package has not yet entered testing even though the 5-day delay is over. Check why.
  • The as-installed testing for this package did not pass (log).
  • The BTS contains 2 bugs tagged help, please consider helping the maintainer in dealing with them.

testing migration

  • This package is part of the ongoing testing transition known as auto-gap. Please avoid uploads unrelated to this transition, they would likely delay it and require supplementary work from the release managers. On the other hand, if your package has problems preventing it to migrate to testing, please fix them as soon as possible. You can probably find supplementary information in the debian-release archives or in the corresponding release.debian.org bug.
  • This package will soon be part of the python3.12-default transition. You might want to ensure that your package is ready for it. You can probably find supplementary information in the debian-release archives or in the corresponding release.debian.org bug.
  • This package is part of the ongoing testing transition known as auto-lcalc. Please avoid uploads unrelated to this transition, they would likely delay it and require supplementary work from the release managers. On the other hand, if your package has problems preventing it to migrate to testing, please fix them as soon as possible. You can probably find supplementary information in the debian-release archives or in the corresponding release.debian.org bug.
  • This package is part of the ongoing testing transition known as auto-singular. Please avoid uploads unrelated to this transition, they would likely delay it and require supplementary work from the release managers. On the other hand, if your package has problems preventing it to migrate to testing, please fix them as soon as possible. You can probably find supplementary information in the debian-release archives or in the corresponding release.debian.org bug.
  • This package is part of the ongoing testing transition known as auto-ecl. Please avoid uploads unrelated to this transition, they would likely delay it and require supplementary work from the release managers. On the other hand, if your package has problems preventing it to migrate to testing, please fix them as soon as possible. You can probably find supplementary information in the debian-release archives or in the corresponding release.debian.org bug.
  • This package is part of the ongoing testing transition known as flint-3.1.2. Please avoid uploads unrelated to this transition, they would likely delay it and require supplementary work from the release managers. On the other hand, if your package has problems preventing it to migrate to testing, please fix them as soon as possible. You can probably find supplementary information in the debian-release archives or in the corresponding release.debian.org bug.
  • This package is part of the ongoing testing transition known as auto-curl. Please avoid uploads unrelated to this transition, they would likely delay it and require supplementary work from the release managers. On the other hand, if your package has problems preventing it to migrate to testing, please fix them as soon as possible. You can probably find supplementary information in the debian-release archives or in the corresponding release.debian.org bug.
  • This package is part of the ongoing testing transition known as auto-pari. Please avoid uploads unrelated to this transition, they would likely delay it and require supplementary work from the release managers. On the other hand, if your package has problems preventing it to migrate to testing, please fix them as soon as possible. You can probably find supplementary information in the debian-release archives or in the corresponding release.debian.org bug.
excuses:
  • Migration status for sagemath (- to 9.2-2): BLOCKED: Rejected/violates migration policy/introduces a regression
  • Issues preventing migration:
  • Updating sagemath introduces new bugs: #984326, #986527, #993149, #998190.
  • Impossible Depends: sagemath -> libec5/20190909-3+b1/amd64
  • Impossible Depends: sagemath -> libec5/20190909-3+b1/arm64
  • Impossible Depends: sagemath -> libec5/20190909-3+b1/i386
  • Impossible Depends: sagemath -> libflint-2.6.3/2.6.3-3/amd64
  • Impossible Depends: sagemath -> libflint-2.6.3/2.6.3-3/arm64
  • Impossible Depends: sagemath -> libflint-2.6.3/2.6.3-3/i386
  • Impossible Depends: sagemath -> libntl43/11.4.3-1+b1/amd64
  • Impossible Depends: sagemath -> libntl43/11.4.3-1+b1/arm64
  • Impossible Depends: sagemath -> libntl43/11.4.3-1+b1/i386
  • Depends: sagemath lcalc
  • Additional info:
  • Piuparts tested OK - https://piuparts.debian.org/sid/source/s/sagemath.html
  • 389 days old (needed 5 days)

news RSS

bugs

all bug history graph
19 (20)
RC
5 (6)
I&N
11
M&W
3
F&P
0
Help
2

patches

Debian
9.2-2 9.5-6 9.5-6
Debian proposed
1