witty
C++ library for webapps [runtime] (transition package)

NEW: Take a look at the new package tracker: tracker.debian.org/pkg/witty

general

source
witty (source, web)
version
3.3.6+dfsg-1.1
maint
Pau Garcia i Quiles (dm)
arch
any all
std-ver
3.9.8.0
VCS
Git (browse)

todo

  • Incorporate and acknowledge the changes from the non maintainer upload.
  • Lintian reports 3 errors and 60 warnings about this package. You should make the package lintian clean getting rid of them.
  • Build log checks report 2 warnings about this package.
  • The package should be updated to follow the last version of Debian Policy (Standards-Version 4.1.4 instead of 3.9.8.0).
  • A new upstream version is available: 4.0.3, you should consider packaging it.
  • The BTS contains patches fixing 1 bug, consider including or untagging it.
  • This package has "Build-Depends: libglew-dev" while glew needs a new maintainer, see O #866743.
  • This package has "Recommends: tinymce" while tinymce needs a new maintainer, see O #863695.
  • This package has "Build-Depends: swftools" while swftools needs a new maintainer, see O #885088.

problems

  • The package has not yet entered testing even though the 5-day delay is over. Check why.
  • The package is severely out of date with respect to the Debian Policy. Latest version is 4.1.4 and your package only follows 3.9.8.0...
  • There were override disparities found in suite unstable:
    • libwtdbopostgres-dev: Override says libdevel - optional, .deb says libdevel - extra
    • libwt-dev: Override says libdevel - optional, .deb says libdevel - extra
    • libwttest10: Override says libs - optional, .deb says libdevel - extra
    • libwt-doc: Override says doc - optional, .deb says doc - extra
    • libwtdbosqlite40: Override says libs - optional, .deb says libdevel - extra
    • libwt-common: Override says libdevel - optional, .deb says libdevel - extra
    • libwtext40: Override says libs - optional, .deb says libdevel - extra
    • libwt-dbg: Override says debug - optional, .deb says debug - extra
    • libwtdbofirebird40: Override says libs - optional, .deb says libdevel - extra
    • witty: Override says libdevel - optional, .deb says libdevel - extra
    • witty-dbg: Override says debug - optional, .deb says debug - extra
    • witty-examples: Override says libdevel - optional, .deb says libdevel - extra
    • libwttest-dev: Override says libdevel - optional, .deb says libdevel - extra
    • witty-doc: Override says doc - optional, .deb says doc - extra
    • libwtext-dev: Override says libdevel - optional, .deb says libdevel - extra
    • libwtdbo40: Override says libs - optional, .deb says libdevel - extra
    • libwthttp40: Override says libs - optional, .deb says libdevel - extra
    • libwtdbosqlite-dev: Override says libdevel - optional, .deb says libdevel - extra
    • libwtdbo-dev: Override says libdevel - optional, .deb says libdevel - extra
    • libwtdbofirebird-dev: Override says libdevel - optional, .deb says libdevel - extra
    • libwtfcgi-dev: Override says libdevel - optional, .deb says libdevel - extra
    • libwtdbomysql40: Override says libs - optional, .deb says libdevel - extra
    • witty-dev: Override says libdevel - optional, .deb says libdevel - extra
    • libwtdbopostgres40: Override says libs - optional, .deb says libdevel - extra
    • libwtdbomysql-dev: Override says libdevel - optional, .deb says libdevel - extra
    • libwthttp-dev: Override says libdevel - optional, .deb says libdevel - extra
    • libwt40: Override says libs - optional, .deb says libdevel - extra
    • libwtfcgi40: Override says libs - optional, .deb says libdevel - extra

testing migration

excuses:
  • Migration status: BLOCKED: Rejected/introduces a regression (please see below)
  • 461 days old (needed 5 days)
  • witty/armel unsatisfiable Depends: libwt40
  • witty/armel unsatisfiable Depends: libwthttp40 | libwtfcgi40 | libwttest10
  • witty/armel unsatisfiable Depends: libwtext40
  • witty/armel unsatisfiable Depends: libwtdbo40
  • witty/armel unsatisfiable Depends: libwtdbosqlite40
  • witty/armel unsatisfiable Depends: libwtdbopostgres40
  • witty/armel unsatisfiable Depends: libwtdbofirebird40
  • witty/armel unsatisfiable Depends: witty-examples
  • witty-dbg/armel unsatisfiable Depends: libwt-dbg
  • witty-dev/armel unsatisfiable Depends: libwt-dev
  • witty-dev/armel unsatisfiable Depends: libwthttp-dev | libwtfcgi-dev | libwttest-dev
  • witty-dev/armel unsatisfiable Depends: libwtext-dev
  • witty-dev/armel unsatisfiable Depends: libwtdbo-dev
  • witty-dev/armel unsatisfiable Depends: libwtdbosqlite-dev
  • witty-dev/armel unsatisfiable Depends: libwtdbopostgres-dev
  • witty-dev/armel unsatisfiable Depends: libwtdbofirebird-dev
  • Updating witty introduces new bugs: #871286.
  • Piuparts tested OK - https://piuparts.debian.org/sid/source/w/witty.html
  • Not considered

news RSS

bugs

all bug history graph
7
RC
1
I&N
4
M&W
2
F&P
0